Website Slow Response Times
Incident Report for MineCentral
Resolved
This incident has been resolved.
Posted Dec 27, 2021 - 00:03 GMT
Identified
The issue has been identified and a fix is being implemented.
Posted Dec 26, 2021 - 23:56 GMT
Investigating
Our website is currently experiencing some issues with performance. We are currently investigating the issue and will update here on progression.
Posted Dec 26, 2021 - 23:55 GMT