Players unable to connect
Incident Report for MineCentral
Resolved
This incident has been resolved.
Posted Jul 15, 2022 - 20:14 BST
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 15, 2022 - 20:10 BST
Investigating
We are currently investigating an incident which is affecting players being able to connect to the network. We are looking into this issue and will provide updates when possible.
Posted Jul 15, 2022 - 20:01 BST
This incident affected: Minecraft Server (Lobby, Central Isles, Duels, BedWars, The Rampage) and MineCentral Testing Server.